Upstream DNS Servers unstable

November 10, Sat
Affected Service: pihole-nl.freek.ws (185.147.34.122) pihole-uk.freek.ws (185.187.240.11)
  • Monitoring
    The Upstream DNS Servers both piholes use (DNS.watch) are currently under attack. This results into either timeouts or very slow page loads. I've temporarily changed the upstream DNS servers to Google's to mitigate this issue. Sadly DNS.watch has no status page nor contact page, so I am unsure if they're aware of these issues. I will continue to monitor the situation.

    21:53, Nov 06 CET
  • Resolved
    It looks like the DNS.watch services have been restored. Therefore both Pi-holes are now using DNS.watch's upstream servers again.

    21:12, Nov 10 CET
Back to current status